fighting for truth, justice, and a kick-butt lotus notes experience.

 
alt

Detlev Poettgen

 

Domino 8.5.1 Custom Notes.Ini Settings still active

 29 April 2010 20:11:41
Wie ich in dem letzten Post ( Domino 8.5.1Drei Fehler ) bereits geschrieben habe, gibt es bei Verwendung von 8.5.1 ein Problem, wenn über Desktop Settings notes.ini Einträge verteilt werden.

Wie allgemein bekannt, besteht die Möglichkeit über einen Custom Setting Eintrag eines Desktop Setting Dokumentes notes.ini Einträge zu verteilen.
Dies funktioniert super, solange man später nicht wieder den INI-Eintrag entfernen will. Es gibt zwar einen Remove-Button, der auch sichtbar den Eintrag entfernt. Aber man wird feststellen, das der nicht mehr vorhandene INI-Eintrag trotzdem auf die Clients per Desktop Setting gepushed wird.

Ursache ist ein aus meiner Sicht vorhandener Fehler in der Desktop-Setting Maske. Wird eine Notes.ini Custom Setting angelegt, wird im Hintergrund ein verstecktes Feld $Pref angelegt.

Image:Domino 8.5.1 Custom Notes.Ini Settings still active

Wie man in obigem Screenshot sieht, habe ich meinen "geliebten" Notes.ini Eintrag ViewsCheckMarkSel=1 als Custom Setting hinterlegt. Im Hintergrund gibt es das $PrefViewsCheckMarkSel-Feld mit dem Wert "1".
Für die Verarbeitung der Desktop-Settings auf dem Client sind die $Pref-Felder entscheidend.

So wird nun der Custom Setting Eintrag mit dem hierfür vorgesehen Remove-Button wieder entfernt, bleibt aber das $Pref-Feld mit dem alten Wert in dem Desktop-Setting Dokument vorhanden und wird somit auch weiterhin auf die Clients gepushed.

Dies führt dazu, das für Sie als Admin die Policy weiterhin Dinge verteilt, von denen Sie eigentlich denken Sie hätten sie wieder entfernt. Das ist frustrierend.

Die einzige Chance die bleibt, ist per kleinem LotusScript Agent das entsprechende Feld löschen!

Für mich ein Bug; die IBM interpretiert mein Support Ticket mehr als Feature Request :-(

Einfach zu Reproduzieren und auch noch vorhanden in 8.5.1 FP2 und der aktuellen 8.5.2 Beta.

PS: Den Agenten kann ich bei Bedarf kurz zumailen. Ich denke jeder weis, was man jetzt mal prüfen sollte :-(




Kommentare

1Christian Henseler  02.05.2010 20:53:24  Domino 8.5.1 Custom Notes.Ini Settings still active

Der Vollständigkeit halber sei erwähnt, dass derselbe Fehler auch bei Location Settings als auch bei Managed Settings auftritt, also nicht nur Notes.ini Settings betroffen sind.

Ich bewerte dies wie Detlev als kritischen Fehler und es ist mir unverständlich, dass IBM Support dies nur als Enhancement Request bewertet, da hier ganz klar ein Fehlverhalten vorliegt, also nicht mit "Works as designed" argumentiert werden könnte.

Das perfide an dem Fehler ist nicht, dass man keinen Workaround fände, sondern das man erst einmal auf darauf kommen muss, dass die Settings-Dokumente nicht korrekt aktualisiert werden.

Vielen Dank an Detlev, dass er dies öffentlich gemacht hat.

Wollen wir hoffen, dass es IBM gelingt, einen Fix mit 8.5.1 FP3 oder zumindest 8.5.2 zur Verfügung zu stellen.

2Jürgen Wienecke  26.05.2010 08:35:33  Domino 8.5.1 Custom Notes.Ini Settings still active

Hallo Detlef,

genau mein Thema. Ich kann Dich da nur unterstützen. IBM arbeitet schon eine Weile an meinem PMR zu dem Thema, findet aber keine Lösung.

Ich wäre Dir dankbar, wenn Du mir das Script zusenden könntest. So kann ich hier mein Problem wenigstens lösen.

Danke in voraus.

Jürgen

3Frank Monien  05.07.2010 12:06:33  Domino 8.5.1 Custom Notes.Ini Settings still active

Hallo Detlef,

stecken in derselben Problematik.

Bitte schicke mir doch Deinen Agenten zu.

Herzlichen Dank

Frank Monien

4Mario Hülsenitz  09.11.2011 15:49:18  Domino 8.5.1 Custom Notes.Ini Settings still active

Hallo,

danke für den Tipp, Der Bug ist auch in Version 8.5.2 FP3 noch vorhanden, und hat mich gerade einige Stunden gekostet.

5Christoph Stoettner  25.01.2012 18:07:36  Domino 8.5.1 Custom Notes.Ini Settings still active

Hi, danke für die ausführliche Beschreibung. In 8.5.3 jetzt endlich gefixt!

6Michael Arends  24.09.2013 07:52:02  Domino 8.5.1 Custom Notes.Ini Settings still active

Wir quälen uns auch mit der Problematik... 8.5.3 FP2 ...

Dein Script wäre sehr hilfreich...

Beste Grüße aus Dortmund

Michael A.

Archive